Mastercard Apple Pay Disruptions

Incident Report for Dibsy

Resolved

A fix has been implemented by Visa, and no errors have been observed in the past 30 minutes.
Posted Nov 05, 2025 - 22:02 GMT+03:00

Monitoring

We are currently seeing an issue affecting credit card Mastercard payments made through Apple Pay. This is due to a third-party outage on Mastercard’s side. Other payment methods remain unaffected. We are monitoring the situation and will provide an update once service is restored.
Posted Nov 05, 2025 - 03:30 GMT+03:00
This incident affected: Payment Methods (Cards - Mastercard).