Debit Cards - NAPS System Downtime

Incident Report for Dibsy

Resolved

This incident has been resolved.
Posted Apr 10, 2026 - 16:14 GMT+03:00

Identified

QPAY payments system is currently experiencing system downtime. Therefore, it's possible you are experiencing issues with debit card payments. We will keep monitoring for any inconsistencies and will update this report once the issue is fully resolved.
Posted Apr 10, 2026 - 13:05 GMT+03:00
This incident affected: Payment Methods (Debit Card - NAPS).