External - Apple Pay: minor disruption

Incident Report for Dibsy

Resolved

The incident has been resolved
Posted May 16, 2025 - 22:39 GMT+03:00

Identified

We have identified a minor disruption external to our platform affecting Apple Pay payments.

You may see a decline in successful payments as customers may be unable to pay using this payment method.

We will provide updates as they become available.
Posted May 16, 2025 - 19:42 GMT+03:00
This incident affected: Payment Methods (Apple Pay).