Debit Cards - NAPS System Downtime

Incident Report for Dibsy

Resolved

This incident has been resolved.
Posted Jul 28, 2025 - 19:20 GMT+03:00

Investigating

Qatar Central Bank switch (NAPS) has been experiencing issues since 16:00 GMT+3. Debit card payments may be affected, and some customers might get charged despite a failed error. We’re monitoring the situation and will update once it’s resolved.
Posted Jul 28, 2025 - 18:19 GMT+03:00
This incident affected: Payment Methods (Debit Card - NAPS).