External - Card Payments
Incident Report for Dibsy
Resolved
This incident has been resolved.
Posted Nov 04, 2024 - 19:04 GMT+03:00
Update
Qatar Islamic Bank has acknowledged the issue on their channels. We’ll keep you informed as soon as it’s resolved.
Posted Nov 04, 2024 - 16:46 GMT+03:00
Monitoring
We have identified a major disruption external to our platform affecting card payments made with Qatar Islamic Bank.
You may see a decline in successful payments as consumers may be unable to pay using QIB cards.
We will provide updates as they become available.
Posted Nov 04, 2024 - 16:19 GMT+03:00
This incident affected: Payments (Credit Card - Visa/Mastercard, Debit Card - NAPS, Apple Pay - Visa/Mastercard).