Degraded Performance - Al Rayan Bank Card Transactions

Incident Report for Dibsy

Resolved

This incident has been resolved.
Posted Jul 30, 2025 - 18:30 GMT+03:00

Monitoring

We're currently observing degraded performance affecting a limited number of card transactions issued by Al Rayan Bank. The issue appears to originate from the bank's side.

Our team is monitoring the situation closely and will update you as soon as the issue is resolved or further information becomes available.
Posted Jul 30, 2025 - 18:13 GMT+03:00
This incident affected: Payment Methods (Cards - Visa).